Now, when I started this site almost a year ago I had every intention of keeping it updated for the amusement of of whoever happens to stumble onto this site. The problem is, I haven’t kept it up. So I am going to list 5 cold things which represent the chill that is throttling Norfolk like some kind of ice python!

5# Cold Shoulders

Getting hit with a cold shoulder hurts with an icy sting

4# Cold water on your teeth

This is deeply unpleasant especially in the morning!

…I’ll think of more another time, I must now go and play Skyrim, which incidentally features a lot of snow, ice etc.

Fus Ro Dah!

I recently had to install a CMS on a Microsoft server which had the feel of WordPress Front end while retaining a usable interface back end.

Enter Umbraco, the WordPress for .NET setups. Alone it is a CMS for sites, offering Rich Text Editing and custom Placeholders for your pages editable by users through use of custom Umbraco elements placed in the page code.

This is great. However it isn’t enough functionality to bring anywhere near WordPress levels.

Enter Blog4Umbraco. This compliation of self installing scripts…again GREAT!

BUT before you go installing and whatnot, bear in mind you’re installing for your server and IIS setup. While Blog4Umbraco is great, it is easy to trip up by installing the wrong version with your build of Umbraco.

Here are instructions to flawlessly set up Blog4Umbraco on a 4.5.2 Umbraco build for .NET 3.5:

Download ‘Blog4Umbraco 2.0.26 for 4.5′, and upload to your build via the ‘install local package’ function.

NOTE: It is preferable to install Umbraco v4.5.2 with ‘Blog4Umbraco 2.0.26 for 4.5′ as it fixes a major bug in Umbraco v.4.0.4.2 with ‘Blog4Umbraco_2.0.26′, which prevent filtering posts by month.

Once Blog 4 Umbraco is installed, changes will need to be made to 3 areas:

1 – xslt/BlogListPosts.xslt

Around line 62-63, paste this over the exisiting XSL IF:

Around line 92, paste this over the exisiting XSL FOR EACH:

2 – config/umbracoSettings.xml

There is an issue with the call for the ‘bin’ folder and it’s contents. There are two fixes.

One is to copy and paste the entire bin folder into itself (bin/bin/).

The second involves modifying an XML file which controls dll call structure and will allow blog 4 umbraco to funtion (sorry i dont have the file name to edit to hand! coming soon)

3 – Ping Tab Removal

There is a small bug which throws an error up when saving a blog post. Although an error is shown the post still gets published/saved, and you can check this by right clicking on your ‘Blog’ in the content tree and refreshing your nodes with ‘refresh nodes’. It will appear in the right place.

Go to ‘Settings’ then ‘Document Types’ and then choose ‘Blog’, then navigate to ‘Generic Properties’. Locate ‘Pings’ and delete it. This should fix the bug.

There, you’re done!